This incident has been resolved. We identified the root cause of the email delivery degradation and deployed a fix. Email notifications, including alert emails, are being delivered normally. If you still don't see expected alert emails, please check your spam/junk folder and add no-reply@iot-notifications.com to your safe senders list, or contact our support team.
Posted Sep 23, 2026 - 16:36 UTC
Monitoring
A fix has been implemented and email notification delivery has returned to normal. We are monitoring closely to confirm stability. If you still don't see expected alert emails, please check your spam/junk folder and add no-reply@iot-notifications.com to your safe senders list.
Posted Sep 23, 2026 - 15:33 UTC
Identified
We have identified an issue affecting the delivery of email notifications, including alert emails. Some messages may arrive late or be filtered into spam/junk folders. Our team is actively working on remediation. SMS, webhook and other notification channels are not affected.
In the meantime, we recommend checking your spam/junk folder and adding no-reply@iot-notifications.com to your safe senders list. We will post updates as the situation progresses.
Posted Sep 23, 2026 - 13:38 UTC
This incident affected: Ubidots Australia (Private deployment) (Events Engine) and America (Events Engine).