MQTT broker
Incident Report for Ubidots
Resolved
We have been monitoring today the patches deployed yesterday and do not report any additional issue, we consider the incident as closed
Posted Sep 09, 2020 - 22:46 UTC
Identified
During the last days, we have received reports from some of our users related with issues with our MQTT broker. The Development team has been working hard during these days to solve them as soon as they were reported. As a matter of being clear, we would share the traceback of the troubleshooting:

Friday, Sept 4th: We are experiencing issues with some MQTT connections. It appears to be related to selected device tokens not being able to subscribe. A patch has been deployed. We will continue to monitor the MQTT broker.

Sunday, Sept 6th: We have received some reports of degraded MQTT connection attempts for newly-created tokens. We have deployed a temporary patch and will continue to monitor the MQTT broker.

Tuesday, Sept 8th: We continue to experience degraded MQTT-subscribe performance for newly-created tokens. A fix has been deployed to solve this for account tokens and device tokens. Currently, we detected that the issue persists only for newly created organizational tokens.
Posted Sep 09, 2020 - 03:24 UTC