[UbiFunction] Module experiencing degradation

Incident Report for Ubidots

Resolved

Summary:
We identified an issue that limited the number of active connections to one of our servers. The root cause was a kernel-level restriction on the maximum number of open files (file descriptors), which also affects network sockets.
Impact:
The limitation caused a temporary reduction in the number of simultaneous connections the server could handle, potentially affecting availability for some users.
Resolution:
The kernel and system-level limits for open files were increased to ensure sufficient capacity for concurrent connections. After applying the changes and restarting the affected services, the system returned to normal operation.
Preventive Actions:
We’ve updated our configuration management to enforce higher default limits across all environments, preventing similar constraints in the future.
Status:
This incident has been fully resolved, and all systems are operating normally.
Posted Nov 01, 2025 - 15:12 UTC

Monitoring

We have restarted the load balancer for the UbiFunction module. This has restored the operation in the module.
Posted Oct 31, 2025 - 13:53 UTC

Investigating

We’ve identified an issue affecting the UbiFunction module. Our DevOps team is currently investigating the root cause.
Posted Oct 31, 2025 - 13:28 UTC
This incident affected: Functions.