Generalized latency

Incident Report for Ubidots

Resolved

This incident has been resolved.
Posted Jun 11, 2025 - 14:28 UTC

Investigating

We're experiencing a generalized latency in the platform. Our DevOps team is already working on resolving this issue.
We will provide additional information as it becomes available.
Posted Jun 10, 2025 - 16:47 UTC
This incident affected: America (Login Apps).